Re: Error after screen saver running for a while

Post your questions, bug reports and feature requests here
Post Reply
adampaul
Posts: 1
Joined: Sun Mar 18, 2018 4:33 pm

Error after screen saver running for a while

Post by adampaul » Sun Mar 18, 2018 4:40 pm

Hello,

I'm evaluating gPhotoShow Pro as a photo screen saver, and will cheerfully purchase it at the end of the evaluation period, however I am getting an error after it runs for a while. It will work fine for ~10-15 minutes, and then stop scrolling, and on the bottom right flickers an error:
Could not load <FILE> may be corrupt or unsupported format
This error flickers quickly, once for every file in my photos folder. The files are not corrupt, however, and load just fine in other applications (and all of them, including the ones that are scrolling correctly, were created the exact same way at the same time (JPG export from Lightroom)).

Thinking the problem could be related to the files being on my NAS and it, or the network between it & my PC going to sleep, I copied the files to a local disk and had the same issue.

I enabled logging and here is an excerpt - the same pattern is repeated many many times:
18-3-2018 11:6:9 : ChooseImageFile(1),0
18-3-2018 11:6:9 : WeightedRandom: 38, total=186
18-3-2018 11:6:9 : ChooseImageFile: List Size 186, Selected 38 (E:\Exports\backdrops\P1000832-ts3.jpg)
18-3-2018 11:6:9 : ChooseImageFile: Added image to back list E:\Exports\backdrops\P1000832-ts3.jpg
18-3-2018 11:6:9 : LoadNewImage: Monitor 1 Loading file E:\Exports\backdrops\P1000832-ts3.jpg
18-3-2018 11:6:9 : Error 2 loading file=E:\Exports\backdrops\P1000832-ts3.jpg
18-3-2018 11:6:9 : Working Set Size : 07dd2000 (125.82 Mb)
18-3-2018 11:6:9 : Peak Working Set Size: 12875000 (296.46 Mb)
18-3-2018 11:6:9 : ChangeBitmap: LoadNewImage er=-1
Any ideas? System is running Windows 10 w/dual monitors

Thanks!
Adam
Last edited by adampaul on Sun Mar 18, 2018 7:08 pm, edited 1 time in total.

User avatar
gpb
Site Admin
Posts: 431
Joined: Mon Dec 19, 2011 1:23 am

Re: Error after screen saver running for a while

Post by gpb » Sun Mar 18, 2018 7:07 pm

Hello,
that kind of error means gPhotoShow was not able to read the file, hard to say the reason. Usually the problem is caused exif tags that could be corrupted or contains something that is not interpreted correctly by the library used by gPhotoShow
Gianpaolo Bottin
gPhotoShow.com

User avatar
gpb
Site Admin
Posts: 431
Joined: Mon Dec 19, 2011 1:23 am

Re: Re: Error after screen saver running for a while

Post by gpb » Mon Mar 19, 2018 4:57 pm

Error 2 means windows GDI+ is not able to load that file, I am not sure about the reason. I suspect file format is not jpeg even if file extension is jpg
You could try to tick the option "Enable Color Management" in Display Options page, in this way instead of using gdi+ gPhotoShow use WIC and maybe it will be able to load those file.
Anyway if you can provide me one of those files I can check which is the problem
Gianpaolo Bottin
gPhotoShow.com

zapsmackos
Posts: 4
Joined: Wed May 23, 2018 7:21 pm

Re: Error after screen saver running for a while

Post by zapsmackos » Wed May 30, 2018 12:51 am

I've been having this problem too. The slideshow will run fine for a few minutes and then it's just a black screen and every photo it tries to load gives a little error pop up. I'm on Windows 10.

I'm curious if it's an issue with the most recent release (7.4.9 build 998) as I haven't had this problem before. I may downgrade and see if the issue remains.

User avatar
gpb
Site Admin
Posts: 431
Joined: Mon Dec 19, 2011 1:23 am

Re: Re: Error after screen saver running for a while

Post by gpb » Wed May 30, 2018 8:00 am

All gPhotoShow Pro versions loads images in the same way, by default it uses Microsoft GDI+, if Color Management is enabled it uses Windows WIC. So it is unlikely there is any difference between versions released during the last few years.
Gianpaolo Bottin
gPhotoShow.com

Post Reply