Page 1 of 1

Logon screen saver does not respect "disable audio" option for video files

Posted: Tue Jul 28, 2015 10:12 am
by Andrej
I have configured the screen saver to show some video files with "Disable Audio" option. It does work: normally, the videos are shown without audio. But when the sreensaver starts during a Window logon screen, the audio is enabled, which is very distracting.

I configured my gPhotoShow to use VLC for showing video.
I have gPhotoShow Pro 7.2.2.756, Windows 7, VLC 2.2.1.

Re: Logon screen saver does not respect "disable audio" option for video files

Posted: Tue Jul 28, 2015 10:09 pm
by gpb
I don't know the reason, the problem is that video are played by an external player and if it doesn't accept the command to mute audio gPhotoShow has no other way to do it.
Anyway playing video during a logon screen saver is not a good idea. I don't know which windows version are using but all windows after XP doesn't allow DirectX on logon operation so video must be played using alternate (and much slower) methods.

Re: Logon screen saver does not respect "disable audio" option for video files

Posted: Wed Jul 29, 2015 12:26 pm
by Andrej
I wish I could configure a different screen saver for logon, say, without video...

Re: Logon screen saver does not respect "disable audio" option for video files

Posted: Wed Jul 29, 2015 4:36 pm
by gpb
With gPhotoShow Pro you can, settings for the logon screen saver are different from the normal screen saver. Every time you click on the button "Set gPhotoShow and Save" gPhotoShow saves current setting to the location for the logon screen saver. You can also use the gPhotoShow Slideshow Maker, prepare you settings save them to a gss file to reuse them later.

Re: Logon screen saver does not respect "disable audio" option for video files

Posted: Wed Jul 29, 2015 7:15 pm
by Andrej
gpb wrote:With gPhotoShow Pro you can, settings for the logon screen saver are different from the normal screen saver. Every time you click on the button "Set gPhotoShow and Save" gPhotoShow saves current setting to the location for the logon screen saver.

Now I see the reason for the original problem of not disabled audio and I know how to fix it. The problem was that I set "disable audio" after I set the logon screensaver. So I had different settings for logon and for normal screensaver. For logon the audio was not disabled. I just "Set gPhotoShow and Saved" one more time and tested logon screensaver. The video on logon screensaver worked without audio, as expected.

Thank you for your help.

By the way, you may want to improve the documentation on setting logon screensaver.

Re: Logon screen saver does not respect "disable audio" option for video files

Posted: Thu Jul 30, 2015 3:58 pm
by gpb
Thanks for the feeback.
Documentation is the most boring job and always needs improvements :)