Some URLs not loading

Post your questions, bug reports and feature requests here
sl4ppy
Posts: 5
Joined: Wed Jun 03, 2015 5:06 pm

Some URLs not loading

Postby sl4ppy » Wed Jun 03, 2015 5:11 pm

I'm having some trouble with displaying URLs within the screen saver. Most pages work but some pretty basic pages dont load for me.. they just show a blank white page.

If I right click on the web page during the screen-savers white screen and display the source code of the URL, I see the source code just fine...

The pages in question are internal only websites to our organization, or I would share them for debugging.. The pages are very basic javascript graphs...

Are there any steps I can take to figure out what's going on?

edit:
Looking at my log files, it looks like the integrated browser in gPhotoShow renders the web page to an image and then displays the image?? The pages were loading take a second or two to generate their graphs. Is it possible it's just grabbing the image before loading is completed?

3-6-2015 12:59:36 : OnTimer: Enter (WaitDX=0)
3-6-2015 12:59:36 : ChangeBitmapFromTimer: Enter m_BmpChgStep=0, main=0
3-6-2015 12:59:36 : ClearHtml(), Closing Web Browser Window
3-6-2015 12:59:36 : ClearHtml(), Web Browser closed
3-6-2015 12:59:36 : ChooseImageFile(0),0
3-6-2015 12:59:36 : WeightedRandom: 0, total=2
3-6-2015 12:59:36 : ChooseImageFile: List Size 2, Selected 0 (ELB Health.website)
3-6-2015 12:59:36 : ChooseImageFile: Added image to back list ELB Health.website
3-6-2015 12:59:36 : LoadNewImage: Monitor 0 Loading file ELB Health.website
3-6-2015 12:59:36 : VideoRestoreAudio 1
3-6-2015 12:59:36 : Resolved URL=http://<redacted>/elb-health.html?t=4h,7d
3-6-2015 12:59:36 : LoadHtml(), Creating Web Browser Window
3-6-2015 12:59:36 : LoadHtml(), Web Browser created
3-6-2015 12:59:36 : LoadHtml(), Navigating to file: http://<redacted>/elb-health.html?t=4h,7d
3-6-2015 12:59:36 : RestartScrapbook
3-6-2015 12:59:36 : ChangeBitmap: LoadNewImage er=0
3-6-2015 12:59:36 : ChangeBitmapFromTimer: Exit
3-6-2015 12:59:36 : OnTimer: Exit
3-6-2015 12:59:36 : OnNavigateComplete2: http://<redacted>/elb-health.html?t=4h,7d
3-6-2015 12:59:36 : ShowBitmap: Bitmap Empty !
Last edited by sl4ppy on Wed Jun 03, 2015 7:22 pm, edited 1 time in total.

User avatar
gpb
Site Admin
Posts: 406
Joined: Mon Dec 19, 2011 1:23 am

Re: Some URLs not loading

Postby gpb » Wed Jun 03, 2015 9:35 pm

Hello,
the issue is probably caused by the script that generate the graphs.
To display web pages gPhotoShow uses the Internet Explorer ActiveX control, so it should basically behave like Internet Explorer but there are some subtle differences in some objects, I don't know the details but I noticed some pages that use jquery don't work correctly or have errors.
I think the only solution is to debug the script and check where it fails.
Gianpaolo Bottin
gPhotoShow.com

sl4ppy
Posts: 5
Joined: Wed Jun 03, 2015 5:06 pm

Re: Some URLs not loading

Postby sl4ppy » Wed Jun 03, 2015 9:42 pm

Thanks for the quick response!

The scripts don't fail and load completely correctly in a regular browser... Is there a more verbose error logging from GPS?

User avatar
gpb
Site Admin
Posts: 406
Joined: Mon Dec 19, 2011 1:23 am

Re: Some URLs not loading

Postby gpb » Wed Jun 03, 2015 9:48 pm

Unfortunately there is no additional error logging, the Microsoft Web Control offers limited control on what the host application can do.
As I wrote I know there are some pages with lots of javascript that are not displayed correctly because of errors in the scripts but from the gPhotoShow point of view I have no way to understand what's going wrong. The Web Control is a black box, gPhotoShow starts it calls the method to navigate to an url but never knows what happens inside.
Gianpaolo Bottin
gPhotoShow.com

sl4ppy
Posts: 5
Joined: Wed Jun 03, 2015 5:06 pm

Re: Some URLs not loading

Postby sl4ppy » Thu Jun 04, 2015 7:22 pm

WE managed to work around it. :) Server generated graphs that just display images works great!

Thanks gpb!

User avatar
gpb
Site Admin
Posts: 406
Joined: Mon Dec 19, 2011 1:23 am

Re: Some URLs not loading

Postby gpb » Thu Jun 04, 2015 9:18 pm

Great ! :D
Gianpaolo Bottin
gPhotoShow.com


Return to “gPhotoShow Pro (Photo Screen Saver and Slideshow Maker)”

Who is online

Users browsing this forum: No registered users and 1 guest