Encountered an improper argument error bug

Post your questions, bug reports and feature requests here
alauck
Posts: 5
Joined: Fri Jun 27, 2014 3:58 pm

Encountered an improper argument error bug

Postby alauck » Fri Jun 27, 2014 4:15 pm

I found a problem with Wallpaper Slideshow Pro that was a real PITA. I have several groups assigned to different folder slideshows. All worked fine until I removed one folder slideshow and added a new one. I forgot to assign a group to the new folder slideshow. When I clicked OK to exit the Options window I received an error "Encountered an improper argument". I was unable to enter the Settings dialog window. The slideshow icon indicated "Busy". I killed the process and restarted the program...same error. I shut down and restarted the program...same error.

Before uninstalling/reinstalling the application i found the configuration file wallpapersspro.wgs in the \users\username\WallpaperSSPro directory and removed all Groups information and restarted the program. I added back the groups and assigned each folder slideshow to a group as I had originally done. All seems to be working properly now, but this kind of error should not result in such a problem. Perhaps a notification should pop-up if a slideshow is added without a group assigned.

We all have better things to do than troubleshoot odd bugs such as this.

User avatar
gpb
Site Admin
Posts: 404
Joined: Mon Dec 19, 2011 1:23 am

Re: Encountered an improper argument error bug

Postby gpb » Fri Jun 27, 2014 9:00 pm

Hello,
the error "Encountered an improper argument" means that there was an unpredictable error somewhere in the code. The condition of images without a group assigned is of course handled but it is possible that a combination of factors caused that error. Unfortunately the causes of this kind of errors are very hard to find since I am not always able to reproduce them. If you know how to reproduce that error it would greatly help to fix it.
Gianpaolo Bottin
gPhotoShow.com

alauck
Posts: 5
Joined: Fri Jun 27, 2014 3:58 pm

Re: Encountered an improper argument error bug

Postby alauck » Sun Jun 29, 2014 4:55 pm

Apparently, I am doing something wrong when I change the folder to be used for a particular group.

The same error occurred on a second PC that has Wallpaper SS Pro installed. I have four groups (the current group that I have selected to be active is Tmp group). In the main configuration screen I highlight the folder (which is the one Tmp is assigned to) and click Remove. I then Add a different folder and assign the Tmp group to that folder listing. When I exit the configuration screen I get the error "Encountered an improper argument error". I have to go into the wallpapersspro.wgs configuration file and delete all items related to Groups. When I restart Wallpaper SS Pro and add the groups back again all works fine.

What am I doing wrong?

Thanks for your attention to this problem.

User avatar
gpb
Site Admin
Posts: 404
Joined: Mon Dec 19, 2011 1:23 am

Re: Encountered an improper argument error bug

Postby gpb » Mon Jun 30, 2014 9:51 am

You are nothing wrong, it should work. I tried several times to do the same operations but unfortunately I wasn't able to reproduce the error.
Can you send me the file wallpapersspro.wgs before you do those operation and after them (when WallpaperSS starts to give you that error) ?
Using your setting files it should be easier to find what is causing that error.
Gianpaolo Bottin
gPhotoShow.com

alauck
Posts: 5
Joined: Fri Jun 27, 2014 3:58 pm

Re: Encountered an improper argument error bug

Postby alauck » Mon Jun 30, 2014 5:00 pm

I tried to upload the configuration files but I get the error message "The extension is not allowed." I tried using .txt and other extensions, but I get the same error.

User avatar
gpb
Site Admin
Posts: 404
Joined: Mon Dec 19, 2011 1:23 am

Re: Encountered an improper argument error bug

Postby gpb » Mon Jun 30, 2014 5:27 pm

Attached files should be compressed in a zip or rar archive. Anyway I enabled plain text attachments so now it should work.
Gianpaolo Bottin
gPhotoShow.com

alauck
Posts: 5
Joined: Fri Jun 27, 2014 3:58 pm

Re: Encountered an improper argument error bug

Postby alauck » Mon Jun 30, 2014 5:50 pm

I have attached a ZIP file containing the config file when I received the error (wallpapersspro-org.wgs) and the file after I removed the Groups entries (wallpapersspro.wgs).

The items I removed from the original config file were:
NumGroups=5

GroupName0=Tmp
GroupName1=Tmp2
GroupName2=Wst
GroupName3=Sample1
GroupName4=Sample2

I did add back some Groups in the current configuration file.

I appreciate your assistance with this problem.
Attachments
wallpapersspro.zip
(29.1 KiB) Downloaded 1894 times

User avatar
gpb
Site Admin
Posts: 404
Joined: Mon Dec 19, 2011 1:23 am

Re: Encountered an improper argument error bug

Postby gpb » Tue Jul 01, 2014 11:30 am

Thank you very much for the settings file.
I think I found the cause of the problem, a file scan was not performed when one or more groups are changed in the files list. Please download and install this WallpaperSS pro version:
http://www.gphotoshow.com/files/wpsprosetup_3421.exe

Let me know how it works now.
Gianpaolo Bottin
gPhotoShow.com


Return to “Wallpaper Slideshow Pro (Desktop Wallpaper Changer)”

Who is online

Users browsing this forum: No registered users and 1 guest